| <testcase> | |
| <info> | |
| <keywords> | |
| POP3 | |
| SASL | |
| SASL AUTH OAUTH2 | |
| SASL-IR | |
| RFC1734 | |
| RFC5034 | |
| RFC6749 | |
| RFC7628 | |
| </keywords> | |
| </info> | |
| # | |
| # Server-side | |
| <reply> | |
| <servercmd> | |
| AUTH OAUTHBEARER | |
| REPLY AUTH + eyJzdGF0dXMiOiJpbnZhbGlkX3Rva2VuIiwic2NvcGUiOiJleGFtcGxlX3Njb3BlIiwib3BlbmlkLWNvbmZpZ3VyYXRpb24iOiJodHRwczovL2V4YW1wbGUuY29tLy53ZWxsLWtub3duL29wZW5pZC1jb25maWd1cmF0aW9uIn0 | |
| REPLY AQ== -ERR Authentication failed | |
| </servercmd> | |
| </reply> | |
| # | |
| # Client-side | |
| <client> | |
| <server> | |
| pop3 | |
| </server> | |
| <name> | |
| POP3 OAuth 2.0 (OAUTHBEARER) failure as continuation with initial response | |
| </name> | |
| <command> | |
| pop3://%HOSTIP:%POP3PORT/890 -u user --oauth2-bearer mF_9.B5f-4.1JqM --sasl-ir | |
| </command> | |
| # The protocol section doesn't support ways of specifing the raw data in the | |
| # base64 encoded message so we must assert this | |
| <precheck> | |
| perl -e "print 'Test requires default test server host and port' if ( '%HOSTIP' ne '127.0.0.1' || '%POP3PORT' ne '9001' );" | |
| </precheck> | |
| </client> | |
| # | |
| # Verify data after the test has been "shot" | |
| <verify> | |
| # 67 - CURLE_LOGIN_DENIED | |
| <errorcode> | |
| 67 | |
| </errorcode> | |
| # | |
| # The multi interface considers a broken "CONNECT" as a prematurely broken | |
| # transfer and such a connection will not get a "QUIT" | |
| <protocol> | |
| CAPA | |
| AUTH OAUTHBEARER dXNlcj11c2VyAWhvc3Q9MTI3LjAuMC4xAXBvcnQ9OTAwMQFhdXRoPUJlYXJlciBtRl85LkI1Zi00LjFKcU0BAQ== | |
| AQ== | |
| </protocol> | |
| </verify> | |
| </testcase> |