| #!/usr/bin/make -f |
| # Sample debian.rules file - for GNU Hello (1.3). |
| # Copyright 1994,1995 by Ian Jackson. |
| # I hereby give you perpetual unlimited permission to copy, |
| # modify and relicense this file, provided that you do not remove |
| # my name from the file itself. (I assert my moral right of |
| # paternity under the Copyright, Designs and Patents Act 1988.) |
| # This file may have to be extensively modified |
| # |
| # Modified to be a prototype for debmake by Christoph Lameter |
| # <clameter@debian.org>. |
| |
| SHELL = /bin/bash |
| |
| build: build-arch build-indep |
| build-arch: build-stamp |
| build-indep: build-stamp |
| build-stamp: Makefile |
| $(checkdir) |
| $(MAKE) |
| touch build |
| |
| Makefile: |
| ./configure --prefix=/usr \ |
| --with-configfile=/etc/watchdog.conf |
| |
| clean: Makefile |
| $(checkdir) |
| [ ! -f Makefile ] || $(MAKE) distclean |
| debconf-updatepo |
| |
| dh_clean |
| rm -f $(find . -name "*.P") |
| rm -rf build-stamp *~ debian/*~ configure-stamp |
| |
| binary-indep: checkroot build |
| $(checkdir) |
| # There are no architecture-independent files to be uploaded |
| # generated by this package. If there were any they would be |
| # made here. |
| |
| binary-arch: checkroot build |
| $(checkdir) |
| dh_clean -k |
| dh_installdirs |
| dh_installdocs README* watchdog.lsm IAFA-PACKAGE \ |
| include/watch_err.h |
| dh_installexamples examples/* |
| dh_installchangelogs ChangeLog |
| dh_installdebconf |
| $(MAKE) install prefix=$$(pwd)/debian/watchdog/usr \ |
| CONFIG_FILENAME=$$(pwd)/debian/watchdog/etc/watchdog.conf |
| cp -p watchdog.conf debian/watchdog/etc/watchdog.conf |
| dh_installinit --noscripts |
| dh_installinit --noscripts --name=wd_keepalive |
| dh_strip |
| dh_compress |
| dh_installdeb |
| dh_shlibdeps |
| dh_gencontrol |
| dh_md5sums |
| dh_fixperms |
| dpkg --build debian/watchdog .. |
| |
| define checkdir |
| test -f debian/rules |
| endef |
| |
| # Below here is fairly generic really |
| |
| binary: binary-indep binary-arch |
| |
| source diff: |
| @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false |
| |
| checkroot: |
| $(checkdir) |
| test root = "`whoami`" |
| |
| .PHONY: binary binary-arch binary-indep clean checkroot |